WordPress поднимает минимально рекомендуемую версию PHP до 7.2

В конце прошлой недели в WordPress наблюдался заметный прогресс в деле внедрения новых версий PHP. Был обновлен ServeHappy API, и теперь минимально допустимой версией PHP стала 7.2, в то время как страница загрузок WordPress рекомендует использовать 7.3 и выше.

Сергей Бирюков закоммиттил это изменение на форумах Meta Trac. Тикет был открыт Мариусом Йенсеном девять дней назад. Ранее виджет консоли ServeHappy выводил уведомление об обновлении пользователям на PHP 5.6 и ниже.

«После обсуждения с командами Site Health и Hosting Team выяснилось, что самым разумным шагом будет сделать вывод уведомления об обновлении пользователям с PHP <= 7.1 (соответственно, ACCEPTABLE_PHP необходимо задать как 7.2)», – отметил Мариус.

«Если взглянуть на цифры, можно видеть, что примерно 25% сайтов, использующих WordPress-версию с ServeHappy, получат уведомление об обновлении».

Отсюда следует, что большинство WordPress-сайтов используют допустимую версию PHP. Примерно 47% работают со старыми версиями. Те, кто работает с WordPress 5.2+ (когда появилась возможность Site Health), получат уведомление об обновлении от ServeHappy API.

Теперь активная поддержка начинается с версии PHP 7.3, а обновления безопасности – с версии PHP 7.2. Команда Site Health запланировала изменение еще в прошлую пятницу, однако Мариус отметил, что вызов API кэшируется в основном неделю в ядре. Соответственно, на этой неделе новое уведомление должно появиться у пользователей.

В декабре 2018 года версии PHP 5.6 и 7.0 достигли конца своего жизненного цикла (EOL) и перестали получать обновления безопасности. В итоге примерно 83% пользователей остались с неподдерживаемыми версиями PHP к концу 2018 года. Сегодня, благодаря прогрессу, достигнутому в рамках проекта Site Health, только 47% используют неподдерживаемые версии PHP. Обновление, введенное на прошлой неделе, должно помочь существенно снизить это число до того, как PHP 7.2 достигнет EOL в ноябре 2020 года.

Дженни Вонг, координирующая проект в команде Site Health, рассказала, как они успешно поработали с разными командами разработчиков, полиглотов, дизайнеров, чтобы сделать возможным это обновление.

«Я помню, как приехала на WordCamp San Francisco и сидела с Эндрю Нейсином и Марком Джекитом на ланче, спрашивая их о том, почему WordPress поддерживает такие старые версии и как они планируют решать это», – отметила Вонг. – «Они рассказали мне о работе, которая велась в тот момент».

«Они рассказали мне о проблемах, выделили время и ответили на все мои вопросы».

Вонг отметила, что ее потрясло участие в этом базовом обсуждении в 2014 году.

«Хочу выразить спасибо полиглотам, которые переводили все то, что мы им подкидывали, всем тем, кто давал отзывы, спорил, боролся, обсуждал, приводил аргументы, делился идеями и патчами, каждой персоне, которая слушала меня, брала мои дикие идеи и претворяла их в жизнь – всем спасибо!», – рассказала Вонг.

Учитывая значительную долю WordPress на рынке, толчок к принятию новых версий позволит сделать сеть более безопасной. Обратите внимание: обновление означает, что теперь 7.2 является низшей границей для PHP, которую можно использовать с WordPress, согласно ServeHappy API. Сайты, работающие на более старых версиях, будут функционировать как и раньше, однако WordPress продолжит настойчиво призывать пользователей к обновлению.

0

Автор публикации

не в сети 6 часов

Brama

1 946
Комментарии: 0Публикации: 336Регистрация: 05-12-2019

Оставьте комментарий

Авторизация
*
*



Регистрация
*
*
*
Генерация пароля